This page describes the system requirements for Dataplane 2.3.7, which requires Jira 7.0 or higher.

Using a different version of Dataplane?  

Jira Compatibility

The following table shows the Arsenale Dataplane releases that are compatible with your Jira Server version.

Jira Version

Compatible Dataplane
Versions 
Jira VersionCompatible Dataplane
Versions
7.5 & newer2.3.75.21.0.0 - 2.2.1
7.42.3.5 - 2.3.75.11.0.0 - 2.0.1
7.32.3.4 - 2.3.75.01.0.0 - 1.8.0
7.22.3.4 - 2.3.7oldern/a
7.12.3.3 - 2.3.7  
7.0.2 - 7.0.102.3.2 - 2.3.7  
7.02.3.1 - 2.3.7  
6.42.2.0 - 2.3.5  
6.31.9.0 - 2.3.5  
6.2.3 - 6.2.71.8.0 - 2.3.5  
6.2 - 6.2.21.6.1 - 2.3.5  
6.11.5.0 - 2.3.5  
6.01.2.0 - 2.2.1  

Jira Data Center

Jira Data Center is Atlassian's clustered, multiple-node high-availability solution for enterprise Jira customers.

The following versions of Arsenale Dataplane are compatible with clustered Jira environments.

Jira Clustering Type

Compatible Dataplane
Versions 
Jira Data Center1.9.0 & newer

Jira Cloud

Arsenale Dataplane does not support Jira Cloud

If you are a current user of Jira Cloud and you wish to use Arsenale Dataplane without the hassle of hosting Jira yourself, one option is to move your Jira installation to the SWIFT service by Seibert Media, which gives you a fully-hosted Jira installation that permits you to install any app, including Arsenale Dataplane, with a setup and free trial process that takes only minutes.

Java Compatibility

Dataplane's Java compatibility requirements are intended to mirror those of Atlassian Jira.

Dataplane officially supports only the Oracle JRE or JDK. Other Java vendors are not supported. The supported versions of Java are based on the compatibility of the underlying version of Jira, as shown below.

Jira VersionSupported Java Versions
7.0+Oracle JRE/JDK 8
6.3 - 6.4
Oracle JRE/JDK 7 or 8
6.0 - 6.2Oracle JRE/JDK 7
5.2Oracle JRE/JDK 6 or 7
5.0 - 5.1Oracle JRE/JDK 6

Database Compatibility

Dataplane's database requirements generally parallel the database requirements for Jira 7.0+.

Before installing Arsenale Dataplane, check your Jira database server against the following list of requirements and recommendations. Some database servers have specific installation requirements that may be different from your current configuration.

 

Database

Supported Versions

Additional Recommendations and Requirements

MySQL

5.1+

Performance tuning of your my.cnf file is strongly recommended but not required. We also recommend granting certain specific privileges to your MySQL database user.

All of these changes are optional and Dataplane will function without any additional configuration, but on moderate-to-large Jira installations, failure to perform this MySQL tuning may cause some reports to run very slowly.

See MySQL Database Performance Tuning for details.

PostgreSQL

8.2+

No special configuration is needed.

PostgreSQL 9.1 or higher is recommended (but not required) for optimal performance.

Oracle

11g+

No special configuration is needed.

MS SQL Server

2008,
2008 R2, 2012, 2014, 2016 and 2017

No special configuration is needed.

SQL Server 2012+ is supported with Jira 6.3 and above.

H2 and/or HSQL

not supported

Jira's built-in H2 and HSQLDB—bundled with Jira for evaluation purposes only—are not supported.

You must switch to a production database before you will be able to use Dataplane.

Database Sizing

Arsenale Dataplane stores all its data in the same database used by Jira.

Depending on the type of Jira issues you have, Arsenale Dataplane's data storage could potentially double your Jira database size or more.

We recommend checking your database server to ensure that you have sufficient space available before installing Dataplane and running the Dataplane indexer.

Page Contents

Copyright © 2017 Arsenale Systems, Inc. · All rights reserved · Contact Us · Powered by Atlassian Confluence